mib2opennms configure issue

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

mib2opennms configure issue

Stephen W. Edge
mib2opennms configure issue When running configure I get message mib2opennms requires smi.h
How do I tell if it is installed correctly and if not where do I get the rpm for RedHat


  

       
                                             ~=~
                                                   {@-@}     
-----------------------------------o00o---(_)---o00o----------------------------------------------------------------
Stephen W. Edge    (770) 654-4447 Cellular with Voice Mail
6155 Ivey Manor Drive    
Cumming, Ga. 30040                 (678) 513-3224 FAX
         swedge@...





------------------------------------------------------------------------------
Throughout its 18-year history, RSA Conference consistently attracts the
world's best and brightest in the field, creating opportunities for Conference
attendees to learn about information security's most important issues through
interactions with peers, luminaries and emerging and established companies.
http://p.sf.net/sfu/rsaconf-dev2dev
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss
Reply | Threaded
Open this post in threaded view
|

Re: mib2opennms configure issue

Benjamin Reed
On 1/17/10 3:39 PM, Stephen W. Edge wrote:
> When running configure I get message mib2opennms requires smi.h
> How do I tell if it is installed correctly and if not where do I get >
the rpm for RedHat

it's in our yum repository:

  http://yum.opennms.org/

See the "Install the Yum Repository RPM" section in the opennms install
instructions:

  http://bit.ly/8scQHX

...and then just "yum install mib2opennms".

--
Benjamin Reed
The OpenNMS Group
http://www.opennms.org/



------------------------------------------------------------------------------
Throughout its 18-year history, RSA Conference consistently attracts the
world's best and brightest in the field, creating opportunities for Conference
attendees to learn about information security's most important issues through
interactions with peers, luminaries and emerging and established companies.
http://p.sf.net/sfu/rsaconf-dev2dev
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss

signature.asc (267 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: mib2opennms configure issue

Stephen W. Edge
When I do it tells me the following I am doing this a root

yum install mib2opennms
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do

When I do ./configure

This is the last lines
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking smi.h usability... no
checking smi.h presence... no
checking for smi.h... no
configure: error: mib2opennms requires smi.h




> From: Benjamin Reed <[hidden email]>
> Organization: The OpenNMS Group
> Date: Sun, 17 Jan 2010 17:02:42 -0500
> To: General OpenNMS Discussion <[hidden email]>
> Cc: "Stephen W. Edge" <[hidden email]>
> Subject: Re: [opennms-discuss] mib2opennms configure issue
>
> On 1/17/10 3:39 PM, Stephen W. Edge wrote:
>> When running configure I get message mib2opennms requires smi.h
>> How do I tell if it is installed correctly and if not where do I get >
> the rpm for RedHat
>
> it's in our yum repository:
>
>   http://yum.opennms.org/
>
> See the "Install the Yum Repository RPM" section in the opennms install
> instructions:
>
>   http://bit.ly/8scQHX
>
> ...and then just "yum install mib2opennms".
>
> --
> Benjamin Reed
> The OpenNMS Group
> http://www.opennms.org/
>
>



------------------------------------------------------------------------------
Throughout its 18-year history, RSA Conference consistently attracts the
world's best and brightest in the field, creating opportunities for Conference
attendees to learn about information security's most important issues through
interactions with peers, luminaries and emerging and established companies.
http://p.sf.net/sfu/rsaconf-dev2dev
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss
Reply | Threaded
Open this post in threaded view
|

Re: mib2opennms configure issue

Benjamin Reed
On 1/17/10 7:21 PM, Stephen W. Edge wrote:
> When I do it tells me the following I am doing this a root
>
> yum install mib2opennms
> Setting up Install Process
> Setting up repositories
> Reading repository metadata in from local files
> Parsing package install arguments
> Nothing to do

So you have the OpenNMS repository RPM installed?

> When I do ./configure
>
> This is the last lines
> checking for sys/types.h... yes
> checking for sys/stat.h... yes
> checking for stdlib.h... yes
> checking for string.h... yes
> checking for memory.h... yes
> checking for strings.h... yes
> checking for inttypes.h... yes
> checking for stdint.h... yes
> checking for unistd.h... yes
> checking smi.h usability... no
> checking smi.h presence... no
> checking for smi.h... no
> configure: error: mib2opennms requires smi.h
Of course, you need to install libsmi.  But, there's still no point in
building yourself on a RedHat system, mib2opennms should be there.

What does "yum repolist" print?

--
Benjamin Reed
The OpenNMS Group
http://www.opennms.org/



------------------------------------------------------------------------------
Throughout its 18-year history, RSA Conference consistently attracts the
world's best and brightest in the field, creating opportunities for Conference
attendees to learn about information security's most important issues through
interactions with peers, luminaries and emerging and established companies.
http://p.sf.net/sfu/rsaconf-dev2dev
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss

signature.asc (267 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: mib2opennms configure issue

Stephen W. Edge
Here are the entry specific to libsmi

libsmi.i386                              0.4.5-5.el4            installed

libsmi.i386                              0.4.5-2            opennms-stable-r
libsmi-devel.i386                    0.4.5-2             opennms-stable-r

 
   
                                                     ~=~
                                                   {@-@}
-----------------------------------o00o---(_)---o00o------------------------
----------------------------------------
Stephen W. Edge
ManagedInfoServices.com    (770) 654-4447 Cellular with Voice Mail
6155 Ivey Manor Drive
Cumming, Ga. 30040                 (678) 513-3224 FAX
          [hidden email]



> From: Benjamin Reed <[hidden email]>
> Organization: The OpenNMS Group
> Date: Sun, 17 Jan 2010 23:45:21 -0500
> To: "Stephen W. Edge" <[hidden email]>
> Cc: General OpenNMS Discussion <[hidden email]>
> Subject: Re: [opennms-discuss] mib2opennms configure issue
>
> On 1/17/10 7:21 PM, Stephen W. Edge wrote:
>> When I do it tells me the following I am doing this a root
>>
>> yum install mib2opennms
>> Setting up Install Process
>> Setting up repositories
>> Reading repository metadata in from local files
>> Parsing package install arguments
>> Nothing to do
>
> So you have the OpenNMS repository RPM installed?
>
>> When I do ./configure
>>
>> This is the last lines
>> checking for sys/types.h... yes
>> checking for sys/stat.h... yes
>> checking for stdlib.h... yes
>> checking for string.h... yes
>> checking for memory.h... yes
>> checking for strings.h... yes
>> checking for inttypes.h... yes
>> checking for stdint.h... yes
>> checking for unistd.h... yes
>> checking smi.h usability... no
>> checking smi.h presence... no
>> checking for smi.h... no
>> configure: error: mib2opennms requires smi.h
>
> Of course, you need to install libsmi.  But, there's still no point in
> building yourself on a RedHat system, mib2opennms should be there.
>
> What does "yum repolist" print?
>
> --
> Benjamin Reed
> The OpenNMS Group
> http://www.opennms.org/
>
>



------------------------------------------------------------------------------
Throughout its 18-year history, RSA Conference consistently attracts the
world's best and brightest in the field, creating opportunities for Conference
attendees to learn about information security's most important issues through
interactions with peers, luminaries and emerging and established companies.
http://p.sf.net/sfu/rsaconf-dev2dev
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss