icmp latency events not generating

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

icmp latency events not generating

saqib
Hello to all

I want to setup ICMP based events that if delay is more than 30ms, event should be generated.

My configurations are

 threshd-configuration.xml
=================

                                 <package name="example1"> 
                <filter>IPADDR != '0.0.0.0'</filter>
                <include-range begin="0.0.0.0" end="255.255.255.255"/>

                <service name="ICMP" interval="300000" user-defined="false" status="on"> 
                <parameter key="thresholding-group" value="icmp-latency"/> 
                                <parameter key="range" value="600000"/>
                </service> 
        </package> 


thresholds.xml
==========

    <group name="icmp-latency" rrdRepository="/opt/opennms/share/rrd/response/">
        <threshold description="latency high" type="high" ds-type="node"
            value="30.0" rearm="15.0" trigger="1" ds-label="icmp"
            triggeredUEI="uei.opennms.org/nodes/icmpThresholdExceeded"
            rearmedUEI="uei.opennms.org/nodes/icmpThresholdrearmed"
            filterOperator="or" ds-name="icmp"/>
    </group>

event file
==========

 <event>
      <mask>
         <maskelement>
            <mename>nodeid</mename>
            <mevalue>.1.3.6.1.4.1.7779.1.1422</mevalue>
         </maskelement>
         <maskelement>
            <mename>generic</mename>
            <mevalue>6</mevalue>
         </maskelement>
         <maskelement>
            <mename>specific</mename>
            <mevalue>4</mevalue>
         </maskelement>
      </mask>
      <uei>uei.opennms.org/nodes/icmpThresholdExceeded</uei>
      <event-label>Latency is High!</event-label>
      <descr>%nodelabel% ,  %interface% has latency</descr>
      <logmsg dest="logndisplay">%nodelabel% ,  %interface% has latency > 30ms. Try ping to  
see the latency!</logmsg>
      <severity>Critical</severity>
   </event>

and this file is included in eventconf.xml

what iam doing wrong here

Thanks in advance
Loading...