OpenNMS doesn't start after upgrade

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenNMS doesn't start after upgrade

Luca_76

Dear all,

this is my first post on this list so I apologize in advance if I do any error. I'm running OpenNMS 20.0 Horizon on Centos 7 without any problem. On yesterday I decided to upgrade from 20.0.0 to the last 20.0.1 as I do once a month when the upgrade is released. The update process worked without error but Opennms doesn't start anymore remaining in start_pending state. In output.log and manager.log I can't see any useful information. I also tried to uninstall it and reinstall clean but the same problem. Can someone give some hint on what can I chake? Is perhaps a new bug?


Thank you in advance


Luca




------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss
Reply | Threaded
Open this post in threaded view
|

Re: OpenNMS doesn't start after upgrade

Roskens, Ronald-2

In $OPENNMS_HOME/etc/log4j2.xml, look for the KeyValuePair for name="manager". If the value isn't DEBUG, then change it to that. That should give you more information during startup as

OpenNMS goes through the initialization and start phases for all its services.

 

I see entries like this:

 

2017-07-28 09:02:24,226 DEBUG [Main] o.o.n.v.Invoker: Invoking start on object OpenNMS:Name=JettyServer

2017-07-28 09:02:44,658 DEBUG [Main] o.o.n.v.Invoker: Invocation start successful for MBean OpenNMS:Name=JettyServer

2017-07-28 09:02:44,658 DEBUG [Main] o.o.n.v.Invoker: pass 1 on service OpenNMS:Name=Syslogd will invoke method "start"

2017-07-28 09:02:44,658 DEBUG [Main] o.o.n.v.Invoker: Invoking start on object OpenNMS:Name=Syslogd

2017-07-28 09:02:44,660 DEBUG [Main] o.o.n.v.Invoker: Invocation start successful for MBean OpenNMS:Name=Syslogd

2017-07-28 09:02:44,671 DEBUG [Main] o.o.n.v.Invoker: completed pass 1

2017-07-28 09:02:44,676 DEBUG [Main] o.o.n.v.Starter: Startup complete

 

Something else to do, is examine other logs that have their timestamps close to when OpenNMS shutdown. One of them might have an explanation for why it shutdown.

# ls -ltr

 

Oh, and you could always run "/opt/opennms/bin/config-tester -a -v" to see if any of the xml files aren't parsing correctly.

 

Ron

 

From: luca comes [mailto:[hidden email]]
Sent: Friday, July 28, 2017 8:34 AM
To: [hidden email]
Subject: [opennms-discuss] OpenNMS doesn't start after upgrade

 

Dear all,

this is my first post on this list so I apologize in advance if I do any error. I'm running OpenNMS 20.0 Horizon on Centos 7 without any problem. On yesterday I decided to upgrade from 20.0.0 to the last 20.0.1 as I do once a month when the upgrade is released. The update process worked without error but Opennms doesn't start anymore remaining in start_pending state. In output.log and manager.log I can't see any useful information. I also tried to uninstall it and reinstall clean but the same problem. Can someone give some hint on what can I chake? Is perhaps a new bug?

 

Thank you in advance

 

Luca

 

 


This e-mail message is being sent solely for use by the intended recipient(s) and may contain confidential information. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by phone or reply by e-mail, delete the original message and destroy all copies. Thank you.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss
Reply | Threaded
Open this post in threaded view
|

Re: OpenNMS doesn't start after upgrade

Reinhard Kuss
In reply to this post by Luca_76
Hi Luca,

you are probably running into an issue with enlinkd. See

http://marc.info/?l=opennms-discuss&m=149980114608703&w=2

and follow the thread to the temporarily solution Alejandro provided (disabling enlinkd). Worked for me.



Am 28.07.2017 um 15:33 schrieb luca comes:

Dear all,

this is my first post on this list so I apologize in advance if I do any error. I'm running OpenNMS 20.0 Horizon on Centos 7 without any problem. On yesterday I decided to upgrade from 20.0.0 to the last 20.0.1 as I do once a month when the upgrade is released. The update process worked without error but Opennms doesn't start anymore remaining in start_pending state. In output.log and manager.log I can't see any useful information. I also tried to uninstall it and reinstall clean but the same problem. Can someone give some hint on what can I chake? Is perhaps a new bug?





Regards
Reinhard

-- 
Reinhard Kuss, office <at> edv-profi24 <dot> at

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss