OpenNMS 19 enlinkd topology missing links Juniper SRX troubleshooting

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenNMS 19 enlinkd topology missing links Juniper SRX troubleshooting

Steven Vacaroaia
Hi,

My SRX3600 does not want to play nice with topology - no links
( enlinkd is using default config - no changes)

Here is what I've done so far:
- make sure SNMP is enabled and provides info
    
- increase enlinkd.log to debug level and check for errors 
ERROR [EnhancedLinkd-Thread-6-of-5] o.o.n.e.NodeDiscoveryBridge: run: collection execution failed, exiting

- check that IP MIBS are available
 snmpwalk -v2c -c "password" 10.10.15.241 .1.3.6.1.2.1.4.20.1.3
IP-MIB::ipAdEntNetMask.10.10.15.241 = IpAddress: 255.255.255.0
IP-MIB::ipAdEntNetMask.10.10.15.242 = IpAddress: 255.255.255.0
IP-MIB::ipAdEntNetMask.10.10.31.10 = IpAddress: 255.255.255.248
IP-MIB::ipAdEntNetMask.10.10.31.33 = IpAddress: 255.255.255.224

- default juniper.xml datacollectionfile contains this 
<systemDef name="Juniper Routers">
        <sysoidMask>.1.3.6.1.4.1.2636.1.</sysoidMask>
        <collect>
          <includeGroup>juniper-router</includeGroup>
          <includeGroup>mib2-X-interfaces</includeGroup>
          <includeGroup>mib2-X-interfaces-pkts</includeGroup>
          <includeGroup>ietf-bgp4-peer-stats</includeGroup>
        </collect>
      </systemDef>

I''ll appreciate any troubleshooting suggestions  

Note
Juniper swtches are displaying links correctly 

Thanks
Steven

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss
Reply | Threaded
Open this post in threaded view
|

Re: OpenNMS 19 enlinkd topology missing links Juniper SRX troubleshooting

Cyrille Bollu
Hi Steven,

Enlinkd can use other links discovery method (eg: LLDP, OSPF).

In my case (juniper switches + SRX4200) , enlinkd is configured as follow:

<?xml version="1.0" encoding="ISO-8859-1"?>
<enlinkd-configuration threads="5"
                     initial_sleep_time="60000"
                     rescan_interval="86400000"
                     use-cdp-discovery="true"
                     use-bridge-discovery="true"
                     use-lldp-discovery="true"
                     use-ospf-discovery="true"
                     use-isis-discovery="true"
                     />

I can see "NodeDiscoveryBridge: run: collection execution failed, exiting" in my logs but topology map is OK as far as I can see (not using it very much though).

I remember though that topology map was not OK until I made sure LLDP data was accessible via SNMP which required the following SNMPv3 configuration in my case:

cyrille@node0-fwlou> show configuration snmp v3 vacm access group opennms
default-context-prefix {
    security-model usm {
        security-level privacy {
            read-view all;
        }
    }
}

cyrille@node0-fwlou> show configuration snmp view all
oid .1;

{primary:node0}


(Before that the snmp view "all" was only showing .1.3.6 which don't include the LLDP MIB)

HTH,

Cyrille

2017-06-19 22:25 GMT+02:00 Steven Vacaroaia <[hidden email]>:
Hi,

My SRX3600 does not want to play nice with topology - no links
( enlinkd is using default config - no changes)

Here is what I've done so far:
- make sure SNMP is enabled and provides info
    
- increase enlinkd.log to debug level and check for errors 
ERROR [EnhancedLinkd-Thread-6-of-5] o.o.n.e.NodeDiscoveryBridge: run: collection execution failed, exiting

- check that IP MIBS are available
 snmpwalk -v2c -c "password" 10.10.15.241 .1.3.6.1.2.1.4.20.1.3
IP-MIB::ipAdEntNetMask.10.10.15.241 = IpAddress: 255.255.255.0
IP-MIB::ipAdEntNetMask.10.10.15.242 = IpAddress: 255.255.255.0
IP-MIB::ipAdEntNetMask.10.10.31.10 = IpAddress: 255.255.255.248
IP-MIB::ipAdEntNetMask.10.10.31.33 = IpAddress: 255.255.255.224

- default juniper.xml datacollectionfile contains this 
<systemDef name="Juniper Routers">
        <sysoidMask>.1.3.6.1.4.1.2636.1.</sysoidMask>
        <collect>
          <includeGroup>juniper-router</includeGroup>
          <includeGroup>mib2-X-interfaces</includeGroup>
          <includeGroup>mib2-X-interfaces-pkts</includeGroup>
          <includeGroup>ietf-bgp4-peer-stats</includeGroup>
        </collect>
      </systemDef>

I''ll appreciate any troubleshooting suggestions  

Note
Juniper swtches are displaying links correctly 

Thanks
Steven

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Please read the OpenNMS Mailing List FAQ:
http://www.opennms.org/index.php/Mailing_List_FAQ

opennms-discuss mailing list

To *unsubscribe* or change your subscription options, see the bottom of this page:
https://lists.sourceforge.net/lists/listinfo/opennms-discuss